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CHAPTER 1 - LAB SESSION  
INTRODUCTION TO EXCEL 

 
INTRODUCTION:  This lab session is designed to introduce you to the statistical 
aspects of Microsoft Excel.  During this session you will learn how to enter and exit 
Excel, how to enter data and commands, how to print information, and how to save your 
work for use in subsequent sessions.  As with any new skill, using this software will 
require practice and patience.  Excel is a spreadsheet used for organizing data in 
columns and rows.  It is an integrated part of Microsoft Office, and so data can be easily 
imported and exported into word processing documents, databases, graphics programs, 
etc.  It offers a wide range of statistical functions and graphs and so is a an alternative to 
specific statistical software.   
 
BEGINNING AND ENDING AN EXCEL SESSION 

To start Excel:  Click on the Start button and choose Programs/Excel.  If you 
have the Office shortcut bar installed, simply click on the Excel icon. 
To exit Excel: 
To end a Excel session and exit the program, choose File from the menu bar and 
then choose Exit.  A dialog box will appear, asking if you want to save the 
changes made to this worksheet.  Click Yes or No.  
You can also exit Excel by clicking the X in the upper right corner of the 
window. 

 
THE EXCEL WINDOWS 

The Document (sheet) Window: 
 When you first start Excel you will be in a window titled “Microsoft Excel - 
Book 1” .  Excel organizes itself in workbooks, each of which is made up of 
worksheets that are 65,536 rows by 256 columns.  You can enter and edit data on 
several worksheets simultaneously and perform calculations based on data from 
multiple worksheets. When you create a chart, you can place the chart on the 
worksheet with its related data or on a separate chart sheet.  Each of the cells 
within the sheet is identified by the intersection of its row and column, for 
example A2, or B7.  
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Note the three tabs and the bottom of the screen, called “sheet1”,”sheet2”, and 
“sheet3”. The default is a workbook with three sheets, but the number of sheets 
in a workbook is limited only by available memory.  To add a single worksheet, 
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between Microsoft Excel Help (F1 key) or the Office Assistant.  You can even 
customize the Office assistant to a varied selection of figures.   He will even 
travel with you from Excel into Word, or any other part of the Office package of 
programs. 

 
 
 

 
ENTERING DATA 

When a workbook is first opened, the cell A1 is outlined in black.  This indicates 
the active cell.  Move your cursor around the sheet, clicking into different cells 
to activate them.  Note that the address changes in the box above A1.  The 
address (row and column) of the active cell always appears here. 
 
Let's enter data in the second column: 

78 94 93 81 75 62 58 50 80 79 
To do this press the down arrow key (↓ ) or enter key to move to the next entry 
position. 
Let’s fill the first column with the numbers 1 through 10.  We can do it the same 
way, or we can let Excel do it for us.  Enter a 1 in cell A1.  Choose Edit > Fill-
>Series.  In the dialog box, select columns, linear, step 1, stop value 10. Then  
click OK. 
 
Column 1 should now contain the integers 1 through 10. 
 
While you are in the sheet window, fill columns 3 and 4 with a set of ten test 
scores each.  You should now have four columns of data.   
 

Changing a value entered 
We can edit data directly in the cell or from the formula bar at the top of the 
sheet.  If you have not hit the Enter key yet, you can simply back space and 
correct your mistake.  If you have entered the data, click on the cell you wish to 
edit to make it active.  You can either retype to overwrite the data, or click into 
the formula bar and edit the entry. 
Suppose we had inadvertently left out a value and we wish to enter it in a 
particular position.  Place the cursor in the cell in which you wish to insert the 
new value.  Click the Insert Cells button on the toolbar.  A dialog box will 
appear, asking which way you wish to move the cells.  A blank cell is created 
and the missing value can be entered.  Entire rows and columns can be added the 
same way.  You can take a short cut to this by using Control +.  
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A cell can be deleted by making the cell active, then  Choose: Edit > Delete 
Cells  or by using Control - 
 
 

Copying Data  
To copy the contents of one cell to another, simply activate the cell and choose 
Edit > Copy from the Menu Bar.  (Control C will also accomplish this.) 
Activate the cell that you want to paste the value into and choose Edit –>Paste 
(or Control V) This can also be done for a range of cells. Activate the upper left 
cell of the range. Press shift and click the lower right corner of the range.  This 
should highlight the entire range.  You can then copy and paste as above. 

 
Cell References:   

Previously, you entered four columns of data.  Click on cell B11.  On the 
Standard Toolbar you will see a summation sign Σ. Click on it and the ten values 
above it will be enclosed in a box. Press enter and the sum of the ten values will 
be in cell B11 . Now activate cell B11, press Control C, highlight cells C11 and 
D11, and press Control V.  This should give you the sums of columns C and D. 
Note what happened in the formula when you copied it.  The references were 
changed to reflect the new column.  This is called a  relative reference. 
 
If you need to preserve the value of a certain cell when copying a formula, you 
will have to use absolute referencing.  This is accomplished by placing $ within 
the address. (  A$6$ would keep the value in cell A6 wherever it was copied to 
within the worksheet.) 

 
 
 
SAVING YOUR WORK 

An Excel workbook contains  all your work; the data, graphs, and all the sheets 
within the workbook.  When you save a project, you save all of your work at 
once.  When you open a project, you can pick up right where you left off.   
The contents of each sheet can be saved and printed separately from the project, 
in a variety of formats.  You can also delete a worksheet or graph, which 
removes the item from the project. 
 

RETRIEVING A FILE 
You can open a wide variety of files with Excel.  Choose File Open to select the 
appropriate one.  There is an Import Wizard that will guide you through the 
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process. 
 

A CD ROM accompanies Johnson/Kuby’s Elementary Statistics, 10/e  This disk 
has data in Excel format for many of the problems in the text.  Follow the 
instructions that accompany the disk for use on your computer. 

 
 
PRINTING: 
 You have many options when it comes to printing from Excel.  Go to the 
standard toolbar and choose the File drop down menu.  The Set Print Area choice allows 
you to select the range of cells you wish to print. 
The Page SetUp dialog box has four tabs that will help you customize your output. You 
can also access this dialog box through Print Preview.  This is a good choice because it 
allows you to play with your selections to get the best layout for your output before you 
commit it to paper. 

 
 
 

ASSIGNMENT:  
1.  Create a data file on your disk that consists of the heights of 15 of your 

classmates (in column 1) and their weights (in column 2). 
 

2. Retrieve the data file created in #1 above, and produce a paper copy 
(commonly called 'hard-copy') to hand in. 

 
3. Retrieve the data file for Exercise 2.21 from the Student Suite CD that 

accompanies the Johnson/Kuby text, and print a hard copy to hand in. 
 



Chapter 1  
Introduction to the TI-84 Plus Graphing Calculator 

       

  
 
 
 
This chapter is a brief introduction to the TI-84 Plus.  The basic commands, keystrokes, 
programs and operations used throughout Elementary Statistics, 10th edition will be described in 
detail. Refer to the picture above frequently as a visual aid to locating the various keys. 

Function Keys

Viewing 
Rectangle 

Keypad

Operations 
Keys 

Stat Mode Key 

Program Key 

Arrow Keys for 
Navigating in Window 

Stat Plot Key 

Built in 
Applications 



The keypad on the TI-84 Plus is virtually identical to the TI-83 Plus.  However, the TI-84+ has 
more RAM, greater processing speed and additional applications.  It also includes a USB cable 
for faster communication with your PC. 

On, Off, Contrast 

 The  key is used to turn the calculator on.   

The key sequence  is used to turn the machine off. There is also a battery saving 
feature built into the TI-84+ that will automatically turn the machine off after approximately 5 
minutes of inactivity. 

Press and hold  then press  to increase the contrast, making text easier to read. 

Similarly, press and hold  and then press   to decrease the contrast and lighten 
the text. 
 

Release either key when you have reached the desired screen contrast. As the contrast is 
adjusted there is a single digit, 0-9, that appears in the top right corner of the screen. This 
number is an indication of the screen contrast (the higher the number, the darker the screen), 
and can be used to gauge the energy level of the batteries in the calculator.  While the TI-84+  
does display a warning message if the batteries are low, if the contrast is set to 9 and the screen 
is still very light, this is also an indication that the four AAA batteries need to be replaced. 

Note:  Failing to replace the batteries immediately will result in having to replace the back   
  up battery.  This will also result in losing all of your programs, lists and data. 
Note:  When replacing the AAA batteries, be sure to change on battery at a time.  Otherwise, 
your memory may be reset and you can lose all of your programs, lists, etc.  

Last Entry, Last Answer:  
 
Each entry, is automatically stored in the TI-84+ memory, even as entries scroll off the screen 
or the calculator is turned off. To recall a previous entry 

press   (ENTRY) To access earlier entries, repeat the keystrokes until the 
desired entry is displayed.   
 
The variable ANS contains the value of the most recent calculation.  In a series of calculations, 

it may be more efficient to press  (ANS) rather than repeating the keystrokes 
that yielded that computation.  For example, consider the following table. 



Quarter Quarterly 
Spending 

Cumulative 
Spending  

1st $324 $324 

2nd $584   

3rd $416   

4th $375   

 
Solution:   
   
To get the 2nd quarter cumulative spending, press  

.  Your screen should 
look like this. 

 
 
To get the 3rd quarter cumulative spending, you can either retype 908 + 416  or you can press 
  

(ANS)  which gives us the 
following screen 
 

 
 
Note:  Any time there is a previous answer stored in Ans, pressing an operation key will 
automatically bring up Ans into the working screen.  For example.  To compute the 4th quarter 

cumulative spending, press  to return the screen 



 

 
 

Graphing Functions:  Graphing functions of the form y = f(x) are done in two steps.  First, 

press  located just under the bottom left corner of the viewing rectangle.  This brings 
you to the screen.. 
 

 
 
You can enter multiple functions and graph them all simultaneously.  However, we typically 
only graph a single function at a time.  Enter the function into Y1 =   
 

Next, we need to set the window.  Press  which brings us to the window settings screen 
to specify the window portion that you want to view.   
 

 
 
The window settings above are common settings.  The Xmin and Xmax buttons specify the X- 
axis and the Ymin and Ymax buttons specify the Y-axis.  These settings will graph your function 
on the following window.. 
 

Finally press  
 



 
 

Note:  We can quickly set the window at these settings using the Zoom key.  Press , then 

arrow down to 6: ZStandard and press  which graphs the function on the following axes 
 

 
 
 
For example.   
 
Graph the function y = 3x -2.   
 
Press 

  to obtain 
 

 
 
 
 
Built-in Statistics:  The TI-84+ has several built-in functions for analyzing data. These are 

located in the STAT menu.  Press  
 

 
 



The EDIT Menu is where data is entered into lists.  The CALC menu allows us to compute 
statistical measures on the data stored in the lists.   Finally, the TEST menu allows us to 
construct confidence intervals and conducts tests of hypotheses.  We will be using the TEST 
menu later in the course. 
 
To move between menus just press the appropriate arrow key. 
 

These are the 3 Menus in  
 
                 EDIT        CALC          TESTS 
 

 
 
 
Plotting Statistical Data:  The STATPLOT menu is used to set up various statistical plots.  

Press (STATPLOT).  Which brings us to the following screen 
 

 
 
Again, the TI-84+ has the capability of plotting 3 statistical plots simultaneously.  We will usually 
plot only one at a time.  It is recommended that users only use Plot1.  To set up Plot 1, press 

 
 

 
 



You navigate through the Plot1 menu by use of the appropriate arrow keys.  Notice that the 
calculator has 6 plots listed under Type:    In particular, the TI-84+ can plot scatterplots, 
frequency polygons, histograms, boxplots, and ogives.  In Chapter 2 we will learn how to set up 
and use the STATPLOT menu 
 
Programs:  The CD accompanying the text includes programs for the TI-84+.  At the end of this 
chapter, we will load these programs to our calculator for use later in the text.  To see a list of 

programs already loaded onto your calculator, press .  Your screen will probably look 
like this.  This means that you have no programs loaded on the calculator.   

 

After loading the programs in chapter 2, your PRGM screen will look something like this. 
 

 
 
The EXEC menu is used to run a program.  The EDIT menu is where programs are written or 
changed.  The NEW menu allows us to create or write new programs.  Here are the 3 menus 
 
EXEC    EDIT    NEW 
 

 
 
Lists: A TI-84+ list is a set of numbers or observations. A list can hold up to 999 numerical 
values and is the principal way to store data for analysis.  Many of the built-in statistical 
functions and programs operate on or use data stored in a list or lists during execution.   
There are six simple built-in names for lists:  L1, L2, L3, L4, L5, and L6.  To quickly specify a 



list, such as list L1, press  (L1).   

You can also call up a list from the LIST menu.  Press (LIST)  which brings 
you to the following screen.. 
 

 
 
The NAMES, OPS and MATH submenus will be discussed later. 
 
Working with Lists 
 
You can create lists with a descriptive name for easy identification.  The name must be a string 
of up to 5 characters.  The first character must be a letter which may be followed by letters and 
numbers.  The number of lists is limited by the available memory.  This is done primarily from 
the STAT EDIT menu.   
 
For example, let’s create a list called POUND 
 

Press  to view the STAT LIST Editor 
 

 
 

Next, Press (Up Arrow) and  (Right Arrow repeatedly) to come to a blank list 
name. 
 



 
 
Notice the block A in the upper right corner of the viewing rectangle, this means that the editor 
requires a list name that begins with an alpha character. 
   
Type the letters POUND.  Your screen will look like this.. 
 

 
 

and then press .  This returns the screen.. 
 

.   
 
At this point you can arrow down into the POUND list to enter the data. 
 
Note:  Data that is input into a list is stored indefinitely.  There is no special SAVE button to 
save data in a list.  This data is stored until either cleared or deleted.  
 
Input Data into a List 
 
If you want to save the data in a list that you will recognize later, follow the steps immediately 

above to create the list name.  To input data into a list, press select EDIT by pressing 

, then use the  key to arrow over to the list you want to enter data into.  For our 
POUND example, lets enter the following weights into POUND  

8.2 9.6 9.1 6.3 7.8 



 

Press .  This brings you to the screen.. 
 

 
 
Repeat with each of the 5 weights to obtain the list as shown below.. 
 

 
 
Notice that the cursor is at the 6th  position.  Since we entered 5 values this is a good way to 
check to make sure that we have entered the correct number of data values into the list. 
 
Clearing Data from a List 

To clear data from a list from within the STAT LIST Editor, press (up arrow) to 

highlight the list name, press   and then .  The contents of the list will be 
cleared.   
 
NOTE:  Pressing the DEL (Delete) key will delete the list and the listname from the STAT 
LIST Editor Screen. 
  

The TI-84+ Graphing Calculator Guidebook has much more information about lists, including 
other ways they may be created and used. Most of the calculator programs presented in this 
supplement are illustrated using data stored in lists with descriptive names.  However, it is not 
necessary to give each set of data a name.  Rather use the L1 list and clear it for doing homework 
problems and when taking quizzes and tests so as not to overcrowd the STAT LIST Editor with 
data.  

 



Uploading the Statistics Programs on the CD 
 
In order to use the programs referred to on this CD, you must have the following; 
 
 1) TI-84+ graphing calculator 
 2) TI-Connectivity Software installed 
 3) USB Cable for linking the calculator to your PC 
 
For further information contact Texas Instruments at www.ti.com 
   
There are many programs that you will be downloading to your calculator.  As the calculator's 
memory is finite, you may have to delete some programs prior to getting started.  You can check 
your ram and archive memory by pressing 
  

 
 

 
 
Notice the RAM FREE and ARC FREE (Archive) figures.  Typically, your calculator will have 
higher figures than these indicating that your calculator has plenty of both types of memory.  If 
your calculator was used prior to your purchase, there is the possibility that it is overloaded.  If 
your RAM or ARCHIVE are low, you will want to completely reset the calculator before 
uploading the following programs. 

To reset the calculator to its original factory condition, press  
 

Then press  bringing you to this screen.. 

 
 
 
 



Uploading Programs to the TI-84+ 
 
Uploading the programs to the TI-84+ requires a few steps. 
 
Step 1:  Create a folder on your C: drive of your computer labeled Stats Programs. 
 
    Double-Click on My Computer 
    Double-Click on  (Local Drive) C: 
    From the File menu, select New and click on Folder 
    Type in the name Stats Programs  
 
Step 2:  Put the Statistics CD into the CD Rom drive of your PC. 
 Click on the Icon labeled Uploading Programs 
 The software will prompt you for the folder to upload the programs.   
 Click Browse, select C:, Select Stats Programs and then click on Upload.   
 This will transfer a zipped file over to your harddrive containing all the   
 stats programs utilized for this course.      
 Follow the directions on screen to unzip the files into the Stats Programs   
 folder.  Next, Click on Unzip 
 The software will prompt you for the folder to unzip the files to.   
 Click Browse, select C:, Select Stats Programs and Press Unzip Now. 
 
Step 3:  Now the programs are unpackaged in the C:\Stats Programs folder. To transfer these 
 over to the calculator requires the use of the TI-Connectivity software and USB cable 
 available from Texas Instruments.  On your computer Click on the TI-Connect Icon to 
 open the program.  Be sure that the TI-84+ is connected via the USB cable to the PC and 
 make sure that the calculator is turned on. 
 Next Double Click on My Computer 
 Double Click (Local Drive) C: 
 Double Click on Stats Programs 
 Click on Edit, Select All 
 Right Click and select Copy 
 From the desktop, right click on the TI-Connect icon and select Paste 
 The software will transfer all of the programs to the TI-84+ 
 
 Note:  You may also drag and drop each program from C:\Stats Programs onto the TI-
 Connect Icon. 
 
Step 4:  The programs on your calculator are archived and need to be unarchived and      

 stored in RAM.  On your calculator, press  

  One by One, select each program listed with an asterisk (*) and press  
  Repeat step 4 until each program is listed without the asterisk.   
 

Step 5:  Checking your programs.  Click on .  Your screen should now look like this. 



 

  
 
 
You are now ready to use the TI-84+ and this manual.  Refer to each chapter for specific 
instructions and examples as well as tips on use of the TI-84 to complete homework and lab 
assignments.               
  

 
 



CHAPTER 1 - LAB SESSION  
INTRODUCTION TO MINITAB 

 
INTRODUCTION:  This lab session is designed to introduce you to the statistical 
software MINITAB.  During this session you will learn how to enter and exit 
MINITAB, how to enter data and commands, how to print information, and how to save 
your work for use in subsequent sessions.  As with any new skill, using this software 
will require practice and patience. 
 
BEGINNING AND ENDING A MINITAB SESSION 

To start MINITAB 
From the taskbar, choose   
Start > Programs > MINITAB 14 > MINITAB. 
 

 
 

 
     
1 
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To exit MINITAB 
To end a MINITAB session and exit the program, choose File from the menu bar 
and then choose Exit.  A dialog box will appear, asking if you want to save the 
changes made to this worksheet.  Click Yes or No.  
It is also possible to exit MINITAB by clicking the X in the upper right corner of 
the window. 

 
 

In MINITAB, there are three ways to access commands: with menus, the 
Toolbar, and session commands.  The Toolbar is a quick way to issue 
commands.  When you click a button, MINITAB performs an action or opens a 
dialog box, exactly like the corresponding menu command.  To be able to use 
session commands we must enable the command language editor.  To do this, 
choose Editor > Enable Command Language.  Session commands are 
alternatives to menu commands that you can type in the session window or in the 
command line editor. 

 
 
MINITAB WINDOWS 

The main MINITAB window opens when you first start MINITAB.   You will 
be in a window titled “MINITAB - Untitled ” within which a split window is 
shown; one titled “Session” and the other titled “Worksheet 1”.  The Session 
window displays text output such as tables of statistics.  Data windows are where 
you enter, edit, and view the column data for each worksheet.  Another window 
in the MINITAB environment that can be accessed through the Window menu is 
the Project Manager. The Project Manager summarizes each open worksheet. 
Within the Project manager, the History window records all the commands you 
have used.  Graph windows display graphs. 

 
 
Session Window 

The data window is active when you first start MINITAB.  To move to the 
Session Window just point the mouse to the Session Window and click. In older 
versions of Minitab, whenever you issue a command from a menu, its 
corresponding Session command appears in the Session window.  In version 14, 
the command will appear in the History folder within the Project Manager and 
will only appear in the session window if you have enabled the command 
language.  You can also type Session commands directly into the Session 
window at the MTB> prompt.  Throughout these labs, the same typographical 
conventions will be used as in Johnson/Kuby’s Elementary Statistics, 10/e. 
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The Help Window in MINITAB 
Information about MINITAB is stored in the computer.  If you forget how to use 
a command or subcommand, or need general information, you can ask 
MINITAB for help.  There are three methods for accessing Help: choose Help 
from the menu, select “?” from the toolbar, or press F1.  It would be beneficial 
for you to read “How to use Minitab Help” the first time you enter the program 
to help you understand the structures used in Minitab.   

 
Students: Practice using the HELP command by typing the following and 
reading what is presented on the screen:  

 
Menu Commands    
Choose: Help > Help   

            Select:   Index Help on   
Enter:   MEAN                                        

 
The Data Window 
           

Close Help and click in the worksheet. 
 

The worksheet is arranged by rows and columns.  The columns C1, C2, C3,  . . . , 
correspond to the variables in your data, the rows to observations.   In general,  a 
column contains all the data for one variable, and a row contains all the data for an 
individual subject or observation.  You can refer to the columns as C1, C2, or by giving 
them descriptive names.  Click into the column name cell (the blank space below the 
column number).  Name column 2 “Test 1”, column 3 “test 2”, column 4 “test 3” and 
column 5 “Average” 
 
ENTERING DATA 

Now that we are in the data window, let's enter data in the second column: 
78 94 93 81 75 62 58 50 80 79 

To do this press the down arrow key (↓ ) or Enter to move to the next entry 
position. 

 
Suppose we wish to create a column that contains the integers 1 to 10.  Although 
we could enter these numbers directly into the Data window by typing, there is a 
much easier way:  

 
Menu commands     

  Choose:Calc > Make Patterned Data >  
   Simple Set of Numbers  

Enter: Store patterned data in : C1   
   from first value: 1   

to last value: 10  
  Click: OK  
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      NOTE: Use the Tab key to cycle through the prompts in the dialog box. 
 
Column 1 should now contain the integers 1 through 10. 
While you are in the data window, fill columns 3 and 4 with a set of ten test 
scores each.  You should now have four columns of data.   
 

Changing a value entered 
We can edit data directly in the data window.  Let's suppose we had incorrectly 
entered the third data item in the second column.  It should have been a 73.  
Click cell C2 row 3 to make it active.  Type in the correct value and press enter.  
Double-clicking allows insertion of new characters without retyping the entire 
entry. 

 
Suppose we had inadvertently left out a value and we wish to enter it in a 
particular position.  Place the cursor in the cell in which you wish to insert the 
new value.  Click the Insert Cells button on the taskbar.  A blank cell is created 
and the missing value can be entered.   

 
 
A cell can be deleted by making the cell active, then Choose: Edit > Delete 
Cells (or press the Del key). 
 
Rows of values can also be inserted or deleted in a similar manner.  The menu 
command to insert a row is only functional when the data window is active, and 
a row is active.  To make a row active , click the row header (ie.  the row 
number).  An empty row will be added above the active row in the Data window 
and the remaining rows will be moved down.   

 
Menu Commands    

 Choose: Editor > Insert Row  
 
To print your data choose File > Print Worksheet,  make the appropriate 
selections and click  OK 
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Suppose we wish to copy a column into another column.  We can use the COPY 
command instead of reentering the data. 
 
Choose: Data> Copy> Copy columns to columns 

    Enter: Copy from columns: TEST1  
 Select Store Copied Data in columns  (choose from drop down arrow to select  
       Column)  
 Click: OK 
 

To erase an entire column we use the ERASE command. 
 

Menu Commands     
Choose: Data > Erase Variables   
Enter: Columns and constants: select appropriate variable 
Click: OK 

 
SAVING YOUR WORK 
 A MINITAB project contains all of your work; the data, text output from the  

commands, graphs, and more.  When you save a project, you save all of your 
work at once.  When you open a project, you can pick up right where you left 
off.   
The project’s many pieces can be handled individually.  You can create data, 
graphs, and output from within MINITAB.  You can also add data and graphs to 
the project by copying them from files.  The contents of most windows can be 
saved and printed separately from the project, in a variety of formats.  You can 
also discard a worksheet or graph, which removes the item from the project 
without saving it. Let’s save the project and name it “Intro”.  Be sure to note 
where you are saving it. 
 
To open, save, or close a project 

 To open a new project, choose File > New, click Project, and click OK. 
 
 To open a saved project, choose File > Open Project. 
  
 To save a project, choose FILE > Save Project. 
 

To close a project, you must open a new project, open a saved project, or exit 
MINITAB. 
 
 

RETRIEVING A FILE 
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To retrieve the project that we had saved in the previous session: 

 
Menu Commands         
Choose: File > Open Project       
  
Click: Look in drop-down list arrow 
Locate the file 
Double-click: INTRO.MPJ 
Click: OPEN 

 
The data window now displays the test data you saved previously. 

 
A CD ROM accompanies Johnson/Kuby’s Elementary Statistics, 10/e.  Follow 
the instructions that accompany the disk for use on your computer. 

 
 
 

 
ASSIGNMENT:  

1.  Create a data file on your disk that consists of the heights of 15 of your 
classmates (in column 1) and their weights (in column 2). 

 
2. Retrieve the data file created in #1 above, and produce a paper copy 

(commonly called 'hard-copy') to hand in. 
 

3. Retrieve the data file for Exercise 2.21 from the Student’s Suite CD-
ROM that accompanies the Johnson/Kuby text, and print a hard copy to 
hand in. 

 


